首页 Node.js Yarn Webpack Rollup Parcel

npm-deprecate

作废指定包的指定版本

概要

npm deprecate <pkg>[@<version>] <message>

详情

此命令将更新 npm 注册表中指定包所对应的数据条目, 为尝试安装它的所有人提示版本作废的警告信息。

它适用于版本范围以及特定版本,因此你可以执行以下操作:

npm deprecate my-thing@"< 0.2.3" "critical bug fixed in v0.2.3"

请注意,你必须是包的所有者才能作废某些内容。请参阅 owneradduser 帮助主题。

如需取消作废操作,可以为 message 参数指定一个空字符串("")。

请参阅

Last modified February 17, 2018           Found a typo? Send a pull request!

快速入门

私有模块

故障排除

npm 用法

命令行

配置 npm

npm 服务

查看单页文档