首页 Node.js中文文档

尝试 node 的最新稳定版本

Node 0.4、0.6、0.10 和 iojs 都已不再被官方支持。

如果你所使用的 node 版本已不再被官方支持(例如 0.4、0.6 版本)或者是非稳定版(unstable,即版本号为奇数,例如 0.7.x、0.9.x、0.11.x),并且在使用过程中遇到了问题,那很有可能你的问题已经在 node LTS 版本中被解决了。

检查当前所使用的 node 版本:

node -v

Linux 系统中更新 node

对于某些 Linux 分发版本(Debian/Ubuntu 和 RedHat/CentOS),其自带的 node 版本可能落后于当前稳定版。这里有一份 来自 NodeSource 的安装最新版本 node 的指导。

Windows 系统中更新 node

https://nodejs.org/download 下载最新的 msi 安装包并安装。

OSX 系统中更新 node

https://nodejs.org/download 地址下载并安装最新版本

或者通过 homebrew 安装

brew install node

保持版本更新的简单方式

Node.js 发布了很多版本,并且开发很活跃。管理这些版本的最佳方式是使用一个版本管理器。有很多版本管理器可供选择,下面列出一部分:

Last modified December 13, 2017           Found a typo? Send a pull request!

快速入门

CLI 命令

npm 的工作原理

私有模块

故障排除

使用 npm

配置 npm

npm 服务

查看单页文档